Buugle Chrome

Я использую бета-версию Google Chrome и иногда этот нехороший человек браузер не хочет обновляться, в About появляется кнопка перезапуска браузера, но обновление не происходит.

Решение нашел методом тыка :-D. Для обновления нужно зайти в каталог

X:\Documents and Settings\USERNAME\Local Settings\Application Data\Google\Chrome\Application

Там будет несколько каталогов с разными версиями, файлы chrome.exe и new_chrome.exe.

Закройте браузер, удалите все каталоги со старыми версиями и файл chrome.exe, а файл new_chrome.exe переименуйте в chrome.exe.

Все, запускайте.

P.S.

Быстро найти оригинальное расположение файла/программы по ярлыку вам поможет хак из этой статьи.


Теги: , , , , , , , , , , ,

Adobe Plugins Epic Fail (part2)

В предыдущем посте я писал о плагинах Adobe. Я удалил все плагины Adobe из системы, проверил в обоих браузерах, чтобы среди плагинов они не значились, установил по новой – и вот что получилось:

Adobe, мы тебя .


Теги: , , , , , ,

Plugin Check: Adobe Epic Fail

Пользователи Mozilla FireFox наверняка знают замечательную страницу Plugin Check. А еще пользователи Microsoft Windows знают, что систему нужно регулярно обновлять, иначе вирусы пробьют даже защиту фаерволов и антивирусов. Особенно это касается обновления всяких сторонних приложений, таких как Adobe Flash, Adobe Reader, Adobe Shockwave и т.д.

Я не зря упомянул именно продукты Adobe. Они очень часто становятся тем самым слабым (читать: дырявым) звеном в цепочке Windows.

Я зашел на страницу проверки плагинов в двух браузерах – Google Chrome и Mozilla Firefox. Оба браузера последних версий. Оказалось, что у меня несколько устаревших плагинов: Shockwave for Director, DivX Web Player, RealPlayer Version Plugin, DivX Player Netscape Plugin и Adobe Acrobat.

Пройдясь по всем ссылкам, я обновил все плагины. Выполнял я это в Chrome, но не суть важно. После перезапуска браузеров предо мной появилась чудная картина – Chrome: Shockwave for Director :: Outdated Version, Firefox: Adobe Acrobat :: Outdated Version.

Повторное обновление в Chrome ситуацию не исправило. В Firefox тоже. Более того, Adobe делает вещь, которую я терпеть не могу – устанавливает программу-загрузчик для своего программного обеспечения. Спрашивается: нахрена зачем?

Мало того, что это ублюдочное приложение не отличается функциональностью (я вообще привык к штатным адекватным даунлоадерам FF и Chrome), так оно еще и не работает.

Загрузка обновлялки штатными средствами ФФ тоже не спасла ситуацию, плагин так и не обновился.

Попробую перманентно поудалять все нахрен из системы и загрузить по новой.


Теги: , , , , , , , , , , , , , , ,

Обновление WordPress

Маленький финт ушами. Если у вас официальная русская сборка WordPress, а не какая-нибудь левая, то вам может быть очень полезна следующая инструкция обновления.

  1. Установите плагин WordPress Automatic Upgrade. При появлении новой версии WP, в админке будет ссылка на автоматическое обновление.
  2. Запустите автоматическое обновление, но дойдите только до шага, где закачивается новая версия WP.
  3. На этом шаге две опции, скачивание англиской версии и скачивание локализованной, но вторая опция отключена. Согласитесь скачать английскую версию. Далее вручную скачайте русскую версию и закачайте архив в каталог wpau-backup. Переименуйте каталог wordpress в что-нибудь (*не важно*) или удалите и распакуйте скачанный архив в текущий каталог (wpau-backup!!!). Появится каталог wordpress. Возможно, вам понадобится изменить права этого каталога: chmod –R o+w wordpress. Если не умеете делать такое из консоли, попросите техподдержку. Или попробуйте обновиться не изменяя права. Если не получится, попросите техподдержку сменить права.
  4. Продолжите следующие шаги. Из этого каталога (wpau-backup) будут скопированы локализированные (русифицированные) файлы.
  5. Поздравляю, вы обновились 🙂

Код для пункта #3:

cd wpau-backup
rm -rf wordpress
wget http://ru.wordpress.org/wordpress-X-ru_RU.zip -O wpau-latest.zip
# где X - последняя версия (см. ru.wordpress.org)
unzip wpau-latest.zip
chmod -R o+w wordpress

Теги: , , , , , , ,

Баги в блогах

На днях обновил WordPress до версии 2.8.1. Но вот незадача, появилась версия 2.8.2 и снова нужно обновляться =)
И тут вылез косяк: при обновлении плагинов обновлялка стала отваливаться по таймауту 🙁 Что делать? Поиск привел к хорошей тулзе: Core Control.
Плагин находится здесь: http://wordpress.org/extend/plugins/core-control/
После скачивания плагина, его, как обычно, нужно вручную из панели установить и активировать. После активации зайдите на страницу настроек плагина. Поставьте галочку напротив “HTTP Access Module 0.7” и сохраните настройки. Затем идите на страницу “External HTTP Access” (появится в меню под “Core Control“). На этой странице список транспортов: PHP HTTP Extension, cURL и другие. Потестируйте (“Test Transport”) первые два по очереди и выключите (Disable Transport) тот, который дает ошибку. В моем случае ошибку выдавал первый.

Ошибки, которые у меня были:
”Загрузка не удалась. 200: Operation timed out after 3 seconds with 0 bytes received” (при попытке обновить какой-нибудь плагин)
RSS Error: WP HTTP Error: 200: Operation timed out after 3 seconds with 0 bytes received” (на Доске объявлений)

P.S.
Еще блог не детектил наличие новой версии. Пофиксил тоже с помощью данного плагина: активировал «Plugin, Theme, and Core Updates» и вручную проверил обновления. В общем, для владельцев WP, плагин из разряда must have 🙂


Теги: , , , , , , , , , , , , , ,